Mecaparts - VIN Search is down – Incident details
Get updates
Email
Webhook
API
Get updates
Dark mode
All systems operational
VIN Search is down
Resolved
Major outage
Started 14 days ago
Lasted about 1 hour
Affected
VIN Search
Operational from 8:21 AM to 8:21 AM, Major outage from 8:21 AM to 9:24 AM
Updates
Resolved
October 01, 2025 at 9:24 AM
Resolved
October 01, 2025 at 9:24 AM
VIN Search is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
October 01, 2025 at 8:21 AM
Investigating
October 01, 2025 at 8:21 AM
VIN Search is down at the moment. This incident was automatically created by Instatus monitoring.